Important Update News – What you should know about the new FastViewer version

The new FastViewer version V3.20.0054 will be released on October 4th 2017. This is an important security update, which mainly affects customers who work with or support the Windows XP operating system.

Microsoft has been discontinued the support for Windows XP and Server 2003 since several years. Although this operating system is still working, but it is no longer developed by Microsoft. This could probably lead to security-relevant weak points or attack possibilities.

Data security and data protection has always been the most important priorities that we have committed to our customers. This is also regularly certificated by TÜV Süd, the OPDV as well as the Fiducia – what we are proud of.

In order to ensure the highest possible security standards in the future, Windows XP and Server 2003 are no longer supported with the release of the FastViewer version V3.20.0054.

We therefore ask all customers who are working with Windows XP or who are using the above-mentioned server solution to update their operating system in order to benefit from the new functions and features of the future FastViewer solutions.
You can download the current technical system data sheet here.

If you are not able to switch to a newer operating system, we would like to point out that you can NOT download the new or future versions of FastViewer.

If you have any questions on this subject or need support, do not hesitate to contact us by e-mail at info@fastviewer.com, by telephone at +49 9181 509560 or via button below.

We also recommend you to subscribe to our RSS feed via customer portal, in order to be informed about all future updates and features.

Your FastViewer team